1. Tämä sivusto käyttää keksejä (cookie). Jatkamalla sivuston käyttämistä hyväksyt keksien käyttämisen. Lue lisää.

Ongelma Windows 10 clean install, BIOS ei näytä windows boot manageria

Viestiketju Windows -ongelmat -osiossa. Ketjun avasi Kotirotta 29.03.2020.

  1. Kotirotta

    Kotirotta Member

    Liittynyt:
    03.03.2017
    Viestejä:
    20
    Kiitokset:
    1
    Pisteet:
    13
    Moi,

    Ollut pitkään tilaongelmia vanhalla ssd levyllä ja ostin hieman isomman (128gb->240gb), jotta käyttiksen ja pinnalla olevat pelit saisi mahdutettua yhdelle levylle.

    ONGELMA/TLDR: Windows clean install uudelle ssd:lle ja biosin boot selectionista kun valitsee ssd:n jolle windows on asennettu, tulee ilmoitus "efi part, please remove this media and press any key to reboot".
    [​IMG]

    Kuitenkin jos toistan samat stepit vanhalle ssd:lle, tulee siitä ihan muitta mutkitta bootable drive.
    Selvänä erona on BIOSin boot overridessa vanhan ssdn kohdalla etuteksti "Windows boot manager", mitä ei tuohon uuden ssdn eteen tule, vaikka asentaa windowsin pelkästään uusi ssd kiinni koneessa.
    (HUOM. Vanhalle ssd:lle siis myös tehty diskpartissa clean, ja samalta tikulta samoilla asetuksilla uusi windowsin asennus. Se toimii hyvin, mikä viittoisi siihen suuntaan että jotain tuossa toisessa ssd:ssä on alustamatta/ vialla että ei skulaa. )
    [​IMG]
    Kuva otettu jälkeenpäin kun molemmat ssdt lyöty kiinni.


    -Specsit-
    Emo : Gigabyte Gaming k-3 ax370
    Prossu : Ryzen 5 1600
    Vanha SSD: Intenso 2.5" SATAIII SSD
    Uusi SSD: Kingston A400 248 GB 2.5" SATAIII
    2x WD blue 1TB HDD


    -Itse asennus-

    Eli tähtäimenä oli tehdä "clean install" tikulta uudelle ssd:lle. En voinut käyttää windowsin omaa MediaCreationToolia koska ilmeisesti kyseinen softa ei vaan toimi Sandiskin tikkujen kanssa, eikä muita tikkuja ole lähettyvillä. Eli ISO microsoftilta pienellä kikkailulla (pitää antaa sivun ymmärtää että käyttää jotain muuta käyttistä kuin windowsia, jotta se antaa ladata ison suoraan sen softan sijaan.) ja rufuksella tikulle.

    Latasin microsoftin sivuilta ISO:n, pistin tikun sisään ja ajoin rufuksella tikusta bootablen. Partition scheme GPT ja target system UEFI.

    Sitten muut HDD:t ja vanha ssd irti ja pelkästään uusi ssd ja boottitikku tilalle.


    Boottasin tikulta ja asennus lähti normaalisti käyntiin. Hakeuduin recovery environmenttiin, jotta sain komentolinjan auki jossa pistin diskpartin tulille ja puhdistin koko levyn (select disk <n>, clean) ja converttasin levyn GPT:ksi.
    [​IMG]
    Uusi bootti ja tällä kertaa itse asennusmielessä.
    Asennus sujuu mutkitta.
    Kieli valittu ja muut ToS agreementit tikattu.
    Installeri kysyy mille levylle laitetaan ja antaa vaihtoehdoksi pelkästään sisällä olevan SSD:n ja sillä mennään.
    Asennus ajaa läpi, jonka jälkeen uudelleenkäynnistyksen yhteydessä biosiin -> boot override-> Kingston a4000 -> "EFI part, please remove this media and press any key to reboot"

    *
    *
    *
    *
    Tässä vielä diskmanagerista molempien levyjen( ja tikkukin jäi mukaan) partitioinnit kun molemmat viety windowsin asennukset läpi samoille settingseillä.
    Uudella ssdllä (E: levy ) pelkästään primary partition, kun taasen vanhalla joka boottaa on kuitenkin bootit sun muut tarpeelliset hässäkät.

    [​IMG]

    Ideoita missä kiikastaa?

    ps. Ja kun kumminkin joku kysyy miksi en vain käytä pienemmällä ssdllä käyttistä ja elä sen kanssa, niin vastaus on koska koneessa ollut pidemmän aikaa ongelmana satunnaiset jäätymiset (20-30s)peleissä ja käyttiksessä, niin yritän tässä samalla kartottaa ettei se johdu tuosta (vanhasta) SSD:stä.

    Yritin tunkea mahdollisimman paljon inffoa tähän pätkään, pahoittelut jos meni sekavaksi. Olen vasta pari vuotta ollut tekemisissä näitten koneitten kanssa ja en tiedä esimerkiksi olisiko tuo bootmanager pitänyt manuaalisesti osoittaa tuohon uuteen levyyn , oletan vain että windowsin asennus sen tekisi automaattisesti.

    Joten ongelmaan voi olla joku typeräkin ratkaisu mistä en vain tiedä kaikkea voi tässä kohtaa kokeilla.

    Kiitos jo etukäteen, ihan jo siitä jos joku jaksoi tänne asti lukea koko roskan ja pahoittelut jos teksti on hankalaa luettavaa.
     

    Liitetyt tiedostot:

    Viimeksi muokattu: 29.03.2020
  2.  
  3. Kuunmies

    Kuunmies Senior member

    Liittynyt:
    05.03.2010
    Viestejä:
    4,465
    Kiitokset:
    688
    Pisteet:
    143
    Äsken kokeilin tuota, ja ilman kikkailuja antoi kyllä toi mediacreationtool ladata pelkän ison luomatta tikkua. Itselläkin joskus ollut kyllä ongelmia, kun ohjelma on tehnyt tikun itse.

    Tarkotatko tuolla yllä mainitulla, että kone itsestään menee biosiin, vai valitsetko itse tuon overriden?

    Kysyn nyt vielä varmuudeksi, että olet siis kokeillut laittaa koneeseen vain sen uuden ssd:n, usb-tikku kiinni ja boottivalikon tai jonkun biosin vastaavan override-valikon kautta laittanut käynnistymään kerran tikulta.

    Edit. Mietin vielä tuotakin, että miksi pakastavedetylle levylle piti tehdä noita diskpartin komentoja erikseen?
     
  4. Kotirotta

    Kotirotta Member

    Liittynyt:
    03.03.2017
    Viestejä:
    20
    Kiitokset:
    1
    Pisteet:
    13
    No näinpäs olikin, saa tuon ison sieltä MCT:stä ladattua. Jollakin threadillä eri foorumilla missä puhuttiin tuosta Sandiskin ja MCT:n yhteensopimattomuudesta neuvottiin lataamaan iso microsoftin sivulta iso tekemällä nämä "kikkailut". En sitten sen pidemmin tutkinut vaan oletin ettei iso:a saisi ladattua itse softan kautta.


    Kaikki ihan manuaalisesti.
    Deleteä hakkaamalla biosiin, josta navigoi "boot override" kohtaan josta saa valita levyn miltä käynnistää.
    Sama toiminnallisuus kun konetta käynnistäessä biosin sijaan menisi boot menuun tai vastaavaan ja sieltä valitsee halutun levyn.
    Tarkastelin biosissa samalla aina että kaikki kiinni olevat levyt on tunnistettu ja asetukset oikein, sen takia sitä (biosin ja tämän "boot override") kautta eikä suoraan boot menusta.

    Juu, juurikin näin. Ja kun asennus menee hienosti läpi, ei käyttistä voi käynnistää siltikään ssd:ltä.
    Tästä sitten kummastuin ja kokeilin tehdä saman asennuksen (samalta tikulta, samoilla diskpart käskyillä) tuolle vanhalle ssd:lle, missä kaikki meni hyvin läpi ja käyttis lähti käyntiin ilman mitään ongelmia. Samoilla asetuksilla kokeilin sitten uudestaan uudelle ssd:lle, mutta sama ongelma pulpahtaa minkä kuvasin jo langan alussa.

    Se on hieman pidempi tarina, mutta tiivistettynä siksi että ilman ei lähtenyt ja kaveri kehotti että kokeile tätä.
    Noh, kaverin kehotus oli vähän metsään (ehdotus oli aktiivisen volyymin valitseminen diskpartin kautta, mutta tämä on vain legacy biosia varten - levyille jotka käyttää tuota MBR standardia), mutta sitä selvittäessä tulin siihen tulokseen että vikaan ei voi mennä jos puhdistaa koko roskan ja convertoi sen oikeaan muotoon.
    Näitä diskpart komentoja ei siis ollut ihan ensimmäisessä asennuskerrassa, vaan ne tuli vasta myöhemmin mukaan kuovioon kun olin asentamassa uudestaan windowsia tälle uudelle ssd:lle, johon oli jo asennettu windows kerran (tai 5, en muista enää), ja siellä oli asennuksessa tehdyt partitioinnit valmiiksi ja ne piti saada pois. Lisää siihen vielä pieni sekaannus UEFI:sta ja legacy biosista ja noista "partition schemes" ja alkaa olla sellanen soppa että paras vaihtoehto on vaan mennä diskparttiin, puhdistaa levy ja varmistaa että se on GPT "moodissa" tai "standardissa" mikä nyt onkaan oikea termi.

    Yritin vain kasata kompaktin langan siitä mitä olen yrittänyt ja mikä ei ole ratkaissut ongelmaa, timeline valitettavasti vähän heittelee kun eilisillasta lähes tauotta olen tämän kanssa säätänyt. Nukuin kyllä välissä.
     
  5. Kotirotta

    Kotirotta Member

    Liittynyt:
    03.03.2017
    Viestejä:
    20
    Kiitokset:
    1
    Pisteet:
    13
    Kehtaisin melkein väittää että ongelma on jossain siinä, ettei windowsin asennuksen yhteydessä jostain syystä tuo windows boot manager , mikä ymmärtäkseni on siis softa joka UEFI:ssa osoittaa missä käyttöjärjestelmä on ja mistä se käynnistetään, ei jostain syystä osaa osoittaa missä juuri asentamani käyttis on, tai ei ollenkaan tunnista sitä käyttöjärjestelmäksi.

    Mutta tiedä siitä, tuntuu ihan arvailulta tässä kohtaa.
     
  6. Kuunmies

    Kuunmies Senior member

    Liittynyt:
    05.03.2010
    Viestejä:
    4,465
    Kiitokset:
    688
    Pisteet:
    143
    Näkemättä hommaa, jos kaikki kerta pysyy muuttumattomana eri levyille tapahtuvien asennusten välillä, kyllähän se vaikuttaisi että kingstonissa olisi jotain sanomista.

    Ite varmaan ajaisin vielä secure erasen sille ja kokeilisin vaikuttaako mihinkään.
     
  7. lettas

    lettas Moderator Ylläpitäjä

    Liittynyt:
    03.03.2003
    Viestejä:
    4,241
    Kiitokset:
    178
    Pisteet:
    93
  8. Kotirotta

    Kotirotta Member

    Liittynyt:
    03.03.2017
    Viestejä:
    20
    Kiitokset:
    1
    Pisteet:
    13
    Pariin kertaan kokeiltu mutta tuloksetta. Pistän huomenna kuitenkin tuplatestiin, koska tässä kohtaa en ole enää ihan satavarma mitä olen tehnyt ja mitä en.

    Sen kuitenkin tiedän, että vaikka tuo on ristiriitainen asennus (uefi tikulla ja legacy only SBOC) se ainakin joissakin tilanteissa toimii,
    Koska näillä kyseisillä asetuksilla asensin vanhalle ssd:lleni windowsin uudelleen (tunti sitten) johon para-aikaa latailen ajureita.
    En sitten tiedä olisiko kingstonin lätty jotenkin poikkeus. Tai oikeastaan mitä tämä SBOC säätäminen tarkalleen tekee. Muistaakseni jos koko vaihtoehdon kytkee pois asettamalla CSM (Compatability Support Module) disabled tilaan, toimii asennus siltikin. Siis jos tuon CSM laittaa disabled tilaan, tuo Storage Boot Option Control on "harmaana".
    Villi arvaus on, jos ei mitään aseta niin default on että pelkät UEFI bootit toimii.
     
    Viimeksi muokattu: 29.03.2020
  9. lettas

    lettas Moderator Ylläpitäjä

    Liittynyt:
    03.03.2003
    Viestejä:
    4,241
    Kiitokset:
    178
    Pisteet:
    93
    Jos ei millään lähde toimimaan, niin et paljoa menetä jos teet rufuksella tikusta mbr-muotoisen ja target systemiksi 'bios (UEFI-CSM)'. Windows media creation toolsissa on vanha bugi joka taittui muistaakseni kopioimalla windows media creation tools-exen tikulle ja ajamalla sieltä.
     
  10. Kotirotta

    Kotirotta Member

    Liittynyt:
    03.03.2017
    Viestejä:
    20
    Kiitokset:
    1
    Pisteet:
    13
    Tämä :D täytyypi pistää huomenna kokeiluun.
     
  11. Kotirotta

    Kotirotta Member

    Liittynyt:
    03.03.2017
    Viestejä:
    20
    Kiitokset:
    1
    Pisteet:
    13
    Ei kerennyt eilen säätämään kun oli vähän hommia...

    Eipä lähe MBR:lläkään käyntiin. Kokeilin nyt kaikki kombinaatiot läpi Storage Boot Option Controllin kanssa, mutta ei toimi.

    Tulee kyllä uudenlaista erroria vastaan. Tämä siis installerissa, kun valitsee levun mille haluaa asentaa. Heti kun valitsee levyn, ilmoittaa installeri että ei pysty partitioida levyä ja jos painaa next tulee ilmoitus:

    " Windows Cannot Be Installed to This Disk. This Computer's Hardware May not Support Booting to This Disk."

    Tuli sellanen fiilis, että yrittäis jostain syystä asentaa uefilla. Laitoin biosista kaikki vaihtoehdot "legacy only" mitä löytyi, mutta ei.

    Pikasen googlailun jälkeen löyty, että saattaa olla SATA porttien moodi väärin. Biosista löytyi AHCI:n lisäksi vain RAID, jota päätin silti kokeilla mutta tuloksetta. Istalleri ei edes löytänyt koko levyä joten jätin sen homman sikseen.


    Alan pikkuhiljaa luovuttaa tämän tapauksen kanssa, taidan pitää winukan vaan tuolla vanhalla ssd:llä...

    Kaiken järjen mukaan pitäis uefi asennus kyllä onnistua default asetuksilla, taidan ehkä sitä kokeilla vielä kerran jos jotakin olis maagisesti muuttunut tässä parin päivän aikana.
     
  12. tarantella

    tarantella Senior member

    Liittynyt:
    20.10.2012
    Viestejä:
    5,125
    Kiitokset:
    1,037
    Pisteet:
    223
    Palauta Bios Default asetukseen, only UEFI päälle ja AHCI asetus enable sekä fastboot disable. Poista asennuksen aikana kaikki levyosiot asennettavalta levyltä. Lisäksi poista kaikki muut levyt tai ainakin datajohdot. Näillä eväillä asennuksen kyllä pitäisi onnistua jos tikku vaan tehty oikein.
     

Jaa tämä sivu