1. Tämä sivusto käyttää keksejä (cookie). Jatkamalla sivuston käyttämistä hyväksyt keksien käyttämisen. Lue lisää.

[suse9.1] ppäivitys 9.2:een ja dependancy ongelmat

Viestiketju Linux -keskustelu -osiossa. Ketjun avasi DolbyR 23.05.2005.

  1. DolbyR

    DolbyR Regular member

    Liittynyt:
    28.04.2004
    Viestejä:
    512
    Kiitokset:
    0
    Pisteet:
    26
    Olen päivittämässä suseani mutta nyt rupes tökkimään hieman.

    Tässä lista conflicteista,yms. ei tiedä mitä tekisi kun toiset haluaa kirjaston vanhaa versiota,toiset uutta.

    #### YaST2 conflicts list - generated 2005-05-23 09:55:30 ####

    compat 2004.9.6-2 conflict
    Conflicts with:
    qt2.1 requires libpng.so.2
    Conflict Resolution:
    ( ) Do Not Update compat
    ( ) Remove the Conflicting Package
    Delete qt2.1
    ( ) Ignore Conflict and Risk System Inconsistencies
    hwinfo 9.31-1.1 conflict
    Required by:
    3ddiag requires libhd.so.9
    hotplugctl requires libhd.so.9
    sax2 requires libhd.so.9
    yast2-core requires hwinfo >= 9.1-
    yast2-core requires libhd.so.9
    sax2-tools requires libhd.so.9
    Conflicts with:
    saxtools requires libhd.so.8
    kdebase3-Personal requires libhd.so.8
    Conflict Resolution:
    ( ) Do Not Update hwinfo
    ( ) Remove All 5 Conflicting Packages
    Delete susehelp_en
    Delete kdebase3-Personal
    Delete susehelp
    Delete saxtools
    Delete sax2
    ( ) Remove All 51 Referring Packages
    Delete susehelp_en
    Delete yast2-backup
    Delete yast2-inetd
    Delete yast2-power-management
    Delete yast2-storage
    Delete yast2-scanner
    Delete yast2-samba-client
    Delete yast2-runlevel
    43 more...
    ( ) Ignore Conflict and Risk System Inconsistencies
    libgcrypt 1.2.0-3 conflict
    Required by:
    dirmngr requires libgcrypt.so.11
    dirmngr requires libgcrypt.so.11(GCRYPT_1.2)
    gnutls requires libgcrypt.so.11
    gnutls requires libgcrypt.so.11(GCRYPT_1.2)
    gpg2 requires libgcrypt.so.11
    gpg2 requires libgcrypt.so.11(GCRYPT_1.2)
    Conflicts with:
    opencdk requires libgcrypt.so.7
    Conflict Resolution:
    ( ) Do Not Update libgcrypt
    ( ) Remove All 2 Conflicting Packages
    Delete opencdk
    Delete gnutls
    ( ) Remove All 7 Referring Packages
    Delete susehelp_en
    Delete cryptplug
    Delete kdebase3-Personal
    Delete susehelp
    Delete newpg
    Delete dirmngr
    Delete gnutls
    ( ) Ignore Conflict and Risk System Inconsistencies
    Select libsqlite.so.0
    Required by:
    digikam requires libsqlite.so.0
    Conflict Resolution:
    ( ) Install simias
    ( ) Install sqlite
    ( ) Remove the Referring Package
    Delete digikam
    ( ) Ignore Conflict and Risk System Inconsistencies

    #### YaST2 conflicts list END ###
     
  2.  
  3. lunix

    lunix Regular member

    Liittynyt:
    01.07.2004
    Viestejä:
    773
    Kiitokset:
    0
    Pisteet:
    26
    Paras vaihtoehto, koska en tiedä mitä paketteja olet muista lähteistä kuin virallisista asentanut, olisi tehdä backup /home/<username> hakemistosta ja tehdä uusi(puhdas) asennus.
     
  4. lettas

    lettas Moderator Ylläpitäjä

    Liittynyt:
    03.03.2003
    Viestejä:
    4,388
    Kiitokset:
    211
    Pisteet:
    93
    Ja vinkkinä että kannattaa tosiaan luoda erillinen osio juurelle / ja kotihakemistolle /home. Tuossa tilanteessa helpottaa uudelleenasennusta.
     
  5. DolbyR

    DolbyR Regular member

    Liittynyt:
    28.04.2004
    Viestejä:
    512
    Kiitokset:
    0
    Pisteet:
    26
    ja mitenkäs tuo onnistuu? Nyt on kumminkin 9,2 asennettu, piti vain asentaa eri KDE versio tai jmv. niin sai graafisen puolenkin aukeamaan.
     

Jaa tämä sivu