1. Tämä sivusto käyttää keksejä (cookie). Jatkamalla sivuston käyttämistä hyväksyt keksien käyttämisen. Lue lisää.

Linux Ubuntu 64bit v12.04.2 ja sapphire radeon 4770 ajurien asentaminen

Viestiketju Linux -keskustelu -osiossa. Ketjun avasi pipipaa 03.06.2013.

  1. pipipaa

    pipipaa Regular member

    Liittynyt:
    19.11.2006
    Viestejä:
    152
    Kiitokset:
    1
    Pisteet:
    28
    Morejta morjesta!
    olisi tuollainen otsikon mukainen onkelma,ja erittäin suuri ongelma onkin koska opettelen vasta käyttämään linuxia,eli siis olen täys NEWPIEja erittäin heikko enkku, Koneena toimii asusin M3A emo,Athlonin 64 tuplaydin rossu 6400 ja toi Sapphiren HD 4770 näyttis.Olen yrittänyt muutaman ohjeen mukaan tehdä mut ei vaan asennu noi ajurit


    https://help.ubuntu.com/community/BinaryDriverHowto/ATI#Installing_upstream_drivers_directly_from_AMD.27s_website



    ELIKKÄ MITÄ HEL...TIÄ MUNPITÄIS TEHDÄ ET NOI AJURIEN ASENTAMINEN ONNISTUS ,koittakaa joku vääntää mulle vaikka rautalangasta noi ohjeet (mielellään suomeksi) ;D
     
    Viimeksi muokattu: 03.06.2013
  2.  
  3. lontoo

    lontoo Member

    Liittynyt:
    05.02.2009
    Viestejä:
    56
    Kiitokset:
    0
    Pisteet:
    16
  4. welmar

    welmar Regular member

    Liittynyt:
    10.06.2007
    Viestejä:
    103
    Kiitokset:
    0
    Pisteet:
    26
    Ubuntussa on lisäajurit ohjelma joka tarjoaa sopivan ajurin asennettavaksi jos on saatavilla. Toki ajurin voi asentaa myös noiden ohjeiden mukaan manuaalisesti mutta siinä ei ole järkeä jos ajurin saa asennettua pakettienhallinan kautta.
     
  5. pipipaa

    pipipaa Regular member

    Liittynyt:
    19.11.2006
    Viestejä:
    152
    Kiitokset:
    1
    Pisteet:
    28
    mullapa eip toi onnistu kun eip löydä lisä ajureita.
     
  6. lontoo

    lontoo Member

    Liittynyt:
    05.02.2009
    Viestejä:
    56
    Kiitokset:
    0
    Pisteet:
    16
    Tämmöinen löytyi Ubuntu Suomi-sivustolta:

    "Huom! AMD on lopettanut uudempien Linux-ytimien tuen HD 2000 - HD 4000 -sarjan korteilta. Jos päivität 12.04.2:een, siirryt ainakin toistaiseksi käyttämään avoimia ajureita jotka eivät ole yhtä nopeita raskaimmissa peleissä."

    Eli jos päivittäisi koko jakelun vaikka versioon 12.10/13.04?
     
  7. pipipaa

    pipipaa Regular member

    Liittynyt:
    19.11.2006
    Viestejä:
    152
    Kiitokset:
    1
    Pisteet:
    28
    NONI NY OLIS PÄIVITETTIY 12.10 VERSIOOON, MUT NY KONE LÄHTEE KYL PÄÄLLE MUT NÄYTTÖ SAMMUU JA SANOO NO SIGNAL,MITÄ NY PITÄIS TEHRÄ NÄÄS
     
  8. juyli

    juyli Active member

    Liittynyt:
    13.05.2005
    Viestejä:
    1,845
    Kiitokset:
    0
    Pisteet:
    66
    Ubuntu 12.10 oli tuo huonompi vaihtoehto, koska sen tuki jää lyhyeksi. Ubuntu 13.04 olisi ollut uusin ja tuorein. Käynnistyyhän grub? Editoi e-näppäimellä kernel-riville parametri nomodeset, josko auttaisi. Tämän jälkeen asenna kaikki jakeluun tarjollaolevat päivitykset.
    Uskoisin, että näytönohjaimesi toimisi parhaiten Ubuntu mukana seuraavilla AMD/Ati -ajureilla, jotka jo oletuksena asentuvat.
     
  9. pipipaa

    pipipaa Regular member

    Liittynyt:
    19.11.2006
    Viestejä:
    152
    Kiitokset:
    1
    Pisteet:
    28
     
  10. juyli

    juyli Active member

    Liittynyt:
    13.05.2005
    Viestejä:
    1,845
    Kiitokset:
    0
    Pisteet:
    66
    Tuo tarkoittaa ns. "puhdasta asennusta" eikä varsinaista päivitystä jakelusta seuraavaan (12.04->12.10).
    Kun (ei siis jos ;) ) saat Ubuntu 12.10 Quantal -version toimimaan, voit halutessasi päivittää järjestelmän uusimpaan 13.04 Raring -versioon (update-manager), jonka tuki jatkuu edellistä jakeluversiota pidempään - ja on aina päivitettävissä seuraavaan versioon (13.10, joka julkaistaneen 2013 lokakuussa 10).
    Jos Quantal tai Raring eivät yhäkään vastaa toiveitasi, voit asentaa uudelleen 12.04.x -version, joka on pitkäntuen versio, mutta se tuestaan huolimatta vanhentuu ohjelmien kuin laitetukensakin osalta aikanaan.
     
  11. pipipaa

    pipipaa Regular member

    Liittynyt:
    19.11.2006
    Viestejä:
    152
    Kiitokset:
    1
    Pisteet:
    28
    OK XD Kiitos
     
  12. pipipaa

    pipipaa Regular member

    Liittynyt:
    19.11.2006
    Viestejä:
    152
    Kiitokset:
    1
    Pisteet:
    28
    Viimeksi muokattu: 10.06.2013
  13. lontoo

    lontoo Member

    Liittynyt:
    05.02.2009
    Viestejä:
    56
    Kiitokset:
    0
    Pisteet:
    16
    Haasteellinen homma näköjään, mutta jos kokeilis poistaa vanhat ajurit vaikka näin:

    sudo sh /usr/share/ati/fglrx-uninstall.sh
    sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* xorg-driver-fglrx

    Sitten uudestaan asennus:

    sudo add-apt-repository ppa:xorg-edgers/ppa
    sudo apt-get update
    sudo apt-get install fglrx-installer

    Koko ohje löytyy siis -- http://www.techlw.com/2013/01/install-amd-ati-drivers-in-ubuntu.html
     
  14. pipipaa

    pipipaa Regular member

    Liittynyt:
    19.11.2006
    Viestejä:
    152
    Kiitokset:
    1
    Pisteet:
    28
  15. lontoo

    lontoo Member

    Liittynyt:
    05.02.2009
    Viestejä:
    56
    Kiitokset:
    0
    Pisteet:
    16
    sudo apt-get update
    sudo apt-get install fglrx-installer


    Olihan nämä ajettu viimeisen kuvan "http://aijaa.com/4DYCrN" jälkeen?

    Ja sitten reboot...

    sudo shutdown -r
     
  16. pipipaa

    pipipaa Regular member

    Liittynyt:
    19.11.2006
    Viestejä:
    152
    Kiitokset:
    1
    Pisteet:
    28
    KYLLÄ
     
  17. pipipaa

    pipipaa Regular member

    Liittynyt:
    19.11.2006
    Viestejä:
    152
    Kiitokset:
    1
    Pisteet:
    28
    Sain sitten koneen niin sekasin et noilla näytön hommilla et eip enää edes ylä/sivu palkki tuu näkyviin taidan tehdä 1000 kerran uudelleen asennuksen, mutta mutta ohjeita ja apuja otetaan vastaan. Tuli stos mieleen et mitä helkutin ohjelmia mulla pitäis olla et saisin ton 4770 ja catalystcontrollin toimimaan tossa 13.04 64bit ubuntussa
     
    Viimeksi muokattu: 12.06.2013
  18. juyli

    juyli Active member

    Liittynyt:
    13.05.2005
    Viestejä:
    1,845
    Kiitokset:
    0
    Pisteet:
    66
    Jos ylläolevaan Lontoon viestiin on uskominen, ei laitevalmistaja eli AMD/Ati enää tue ko. näytönohjainta Catalyst-ajureillaan, joten on tyytyminen avoimiin (AMD/Atin tukemaan) avoimeen ajuriin, joka asentuu käyttöön jo oletuksena.
    Erityistarpeistasi en tiedä, mutta Atin kortit toimivat ihan kivasti avoimilla ajureilla.
     
  19. pipipaa

    pipipaa Regular member

    Liittynyt:
    19.11.2006
    Viestejä:
    152
    Kiitokset:
    1
    Pisteet:
    28
    Noh nyt uudelleen asenuksen ja päivityksen jälkeen kokeilin tota


    sudo sh /usr/share/ati/fglrx-uninstall.sh
    sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* xorg-driver-fglrx

    Sitten uudestaan asennus:

    sudo add-apt-repository ppa:xorg-edgers/ppa
    sudo apt-get update
    sudo apt-get install fglrx-installer

    niin näyttö sekos ihan kokonaan,eikä antanut kumpaakaan palkeista esille.
    mitäs tän tyhmän miehen pitäis ny tehdä muuta kuin taas uudelleen asennus
     
  20. juyli

    juyli Active member

    Liittynyt:
    13.05.2005
    Viestejä:
    1,845
    Kiitokset:
    0
    Pisteet:
    66
    Varoittelin juuri noista PPA-repoista ja Catalyst-ajureista, jotka eivät siis enää todennäköisesti tue vanhaa HD 4000-sarjan näytönohjainta.

    Nopein tapa on asentaa uudelleen. Hyviä vaihtoehtoja ovat siis Precise 12.04 LTS tai uusin Raring 13.04. Erillisiä näytönohjainajureita ei tarvitse asentaa, jos saat ylipäätään graafisen näytön toimimaan.
    Jos päädyt asentamaan 12.04 LTS -version on se päivitettävissä seuraavaan 14.04 LTS-versioon. Jos taas päädyt Raring 13.04 -versioon kannattaa se aikanaan syksyllä päivittää versioon Saucy 13.10.

    Päivitykset käyvät varsin vaivattomasti updatemanagerin avulla, mutta uudelleenasennus on aina nopeampi vaihtoehto. Asennuksissa pitää vain aina huolehtia haluttujen datojen talteenottaminen.
     
  21. lontoo

    lontoo Member

    Liittynyt:
    05.02.2009
    Viestejä:
    56
    Kiitokset:
    0
    Pisteet:
    16
    Ilmeisesti uudelleen asennuksen jälkeen pitää tyytyä käyttämään noita oletus ajureita, kun Catalyst tukea ei tuohon 4770:aan ole.

    Tai sitten hommaat uudemman näytönohjaimen. Itselläni on ollut kaksi Nvidian ohjainta Ubuntun eri versioissa, eikä ole ollut mitään ongelmia.
     

Jaa tämä sivu