1. Tämä sivusto käyttää keksejä (cookie). Jatkamalla sivuston käyttämistä hyväksyt keksien käyttämisen. Lue lisää.

720p mkv-tiedosto pätkii tekstityksillä.

Viestiketju DivX, XviD ja muut MPEG-4 -formaatit -osiossa. Ketjun avasi zago 04.12.2008.

  1. zago

    zago Member

    Liittynyt:
    03.04.2006
    Viestejä:
    97
    Kiitokset:
    0
    Pisteet:
    16
    Mistähän mahtaa johtua se, että MPC:llä katsoessa CCCP:n, CoreAVC:n ja Haali Media Splitterin kanssa, että 720p-tiedosto alkaa tökkimään, kun siihen lisää tekstitykset? Koneen tehot allekirjoituksen mukaiset eli siinä rajoilla pyörittääkö vai ei. Ilman tekstityksiä näkyy aivan mainiosti, mutta kun liittää tekstitykset niin fps laskee ja ääni menee edelle.

    Ensin ajattelin, että konetehot eivät riitä, mutta kun kokeilin tekstityksiä normaalilaatuisten avi-tiedostojen kanssa, niin niilläkään ei toimi kunnolla. Varmaan asetuksissa jotain häikkää, mutta en kyllä keksi missä. Osaisiko joku auttaa?
     
  2.  
  3. MattiMies

    MattiMies Regular member

    Liittynyt:
    22.03.2007
    Viestejä:
    417
    Kiitokset:
    0
    Pisteet:
    26
    Poista CCCP ja asenna uusin versio ffdshowsta ja kaikista noista, jotka mainitsit, niin ei ainakaan koodekeista pitäisi johtua.
     
  4. zago

    zago Member

    Liittynyt:
    03.04.2006
    Viestejä:
    97
    Kiitokset:
    0
    Pisteet:
    16
    Poistin siis CCCP:n ja asensin ffdshowin uusimman version, mutta ongelmat jatkuvat. Samalla tavalla käy nytkin eli ilman tekstityksiä kyllä toimii, mutta tekstitykset kun lisää niin ei toimi. Voivatko nuo tekstitykset sitten olla niin raskaat, että kun ne lisää, niin koneen tehot yksinkertaisesti eivät riitä. Luulisi etteivät ne niin paljon raskaammat ole.

    Yksi vaihtoehto olisi tietysti polttaa subit kiinni tiedostonvideoon. Mitenköhän se toimii näillä mkv-tiedostoilla. VirtualDubilla ei varmaankaan onnistu?
     
  5. MattiMies

    MattiMies Regular member

    Liittynyt:
    22.03.2007
    Viestejä:
    417
    Kiitokset:
    0
    Pisteet:
    26
    MKV-videoon saa subit muutamassa minuutissa (riippuu kuinka nopeasti kovalevy kirjoittaa) käyttämällä MKVToolnixin mukana tulevaa mkvmerge GUI-ohjelmaa.

    Input välilehdestä valitset videotiedoston ja Attachment-välilehdestä lisäät subit (ainakin .srt- ja .sub-päätteiset käy). Lopuksi pitää painaa Start muxing.
     
  6. zago

    zago Member

    Liittynyt:
    03.04.2006
    Viestejä:
    97
    Kiitokset:
    0
    Pisteet:
    16
    Tuotakin on jo kokeiltu, mutta mkvmerge GUI-ohjelmallahan subit lisätään vain sisään mkv-tiedostoon ja soittimmesta pitää itse osata subit laittaa toimimaan. Tällä tavallakin subien kanssa videon fps laski. Subit pitäisi saada poltettua kiinni siihen videoon niin kuin VirtualDubilla avi-tiedostoihin.
     
  7. MattiMies

    MattiMies Regular member

    Liittynyt:
    22.03.2007
    Viestejä:
    417
    Kiitokset:
    0
    Pisteet:
    26
    En suosittele sitä tapaa, koska siinä menettää laatua ja menee todella paljon aikaa (riippuu prosessorista ja videon koosta).
     
  8. zago

    zago Member

    Liittynyt:
    03.04.2006
    Viestejä:
    97
    Kiitokset:
    0
    Pisteet:
    16
    Näinhän se on, eli täytyy ilmeisesti nöyrtyä parempi laatuisille videopätkille, kun ei kone jaksa pyörittää leffoja subien kanssa. Kyllähän noista toki ilman tekstejäkin selviää, mutta syö silti vähän mukavuutta. Täytyy ilmeisesti ryhtyä siis uuden koneen hankintaan.
     
  9. lettas

    lettas Moderator Ylläpitäjä

    Liittynyt:
    03.03.2003
    Viestejä:
    4,229
    Kiitokset:
    175
    Pisteet:
    93
    Millä ohjelmalla näytät subeja, ffdshow:lla vai vobsubilla? Voit filtterien asetuksita kokeilla molemmilla tavoilla ja vaikuttaako molemmat noin ratkaisevasti fps:in.
     
  10. zago

    zago Member

    Liittynyt:
    03.04.2006
    Viestejä:
    97
    Kiitokset:
    0
    Pisteet:
    16
    No siis VobSub on asennettuna, mutta en oo kyllä ihan varma että kummalla niitä subeja näytetään. En oo mikää sherlock näien kanssa ni tässä saattaa olla vika? Ffdshowsta en oo mitää subeja raksinu pois enkä tehnyt muuta kun asentanut vobsubin.
     
  11. lettas

    lettas Moderator Ylläpitäjä

    Liittynyt:
    03.03.2003
    Viestejä:
    4,229
    Kiitokset:
    175
    Pisteet:
    93
    Ffdshow:ssa subit ei ole oletuksena päällä, jos et asetusta muualta löydä, niin asennettaessa voit ruksia. Media player classicissa oli joko plugin tai filters- kohta, josta löytyy sekä ffdshown että vobsubin asetukset.
     
  12. _Jarvis_

    _Jarvis_ Member

    Liittynyt:
    08.01.2008
    Viestejä:
    59
    Kiitokset:
    0
    Pisteet:
    16
    Mielenkiintoista, itsellä on koneena aivan hirvee lousku verrattuna tuohon sinun koneeseen eikä ainakaan itsellä oo tollasia ongelmia koskaan ollu. CCCP:tä ja CoreAVC:tä käytän. 720p-pätkät pyörii loistavasti, aivan sama onko tekstit vai ei. 1080p-pätkien kanssa kyllä loppuu jo sitten koneesta armotta tehot :( (koneena siis 3 vuotta vanha Acer Aspire läppäri)

    Edit. huomasin juuri että sanoit että käytät Haalia ja CoreAVC:tä samaan aikaan? Jos näin, ota Haali pois käytöstä, CoreAVC on noin 30% nopemapi kuin Haali :p (ffdshow video decoder --> Codecs --> H264/AVC disabled (se valintakohta siinä vieressä missä varmaankin lukee libavcodec, sen muutat disabled) tuolla kyllä pitäis toimia :)
     
    Viimeksi muokattu: 07.12.2008
  13. zago

    zago Member

    Liittynyt:
    03.04.2006
    Viestejä:
    97
    Kiitokset:
    0
    Pisteet:
    16
    Nyt kun rupesin miettimään niin itseasiassa Vobsubilla taisi olla nuo tekstit valitunna. Ilmeisesti niillä pitäsi olla kevyintä?

    Edit: Joo siis tuolta ffdshowsta tosiaan oli valittuna pois tuo x264/avc. Täytyy kokeilla tuota haalin poistoa ja kaikkien uudelleen asennusta huomenissa, kun on enemmän aikaa. Mikä tuo haalin tehtävä siis varsinaisesti on? Jossain ohjeissa se kuitenkin kehotettiin asentamaan yhdessä coreavc:n kanssa.
     
    Viimeksi muokattu: 07.12.2008
  14. zago

    zago Member

    Liittynyt:
    03.04.2006
    Viestejä:
    97
    Kiitokset:
    0
    Pisteet:
    16
    Niin siis nyt kyllä alkaa menemään hiukan sekavaksi. Asensin CCCP:n niin tuoltahan se Haali Media splitter tulee automaattisesti. Pitääkö se siis jättää pois? Menee vaan pata jumiin näiden kanssa, kun tuntuu että noita asetuksia on niin jumalattomasti eikä koskaan tiedä mikä pitäisi ottaa, jotta toimisi parhaiten.

    EDIT: No niin ongelma taisi ratketa. Asensin CCCP:n uudesti ilman Haalia ja sitten CoreAVC:n haalin kanssa niin toimii. Olin tehnyt näin aiemminkin, mutta jostain syystä silloin ei toiminut saa nähdä kuinka kauan näillä nyt juhlitaan vai alkaako jossain vaiheessa taas temppuilemaan. Outoa on se, että prossun käyttöaste on koko ajan sadassa, mutta video pyörii silti äänten kanssa synkassa ja fps:n laskua ei huomaa ainakaan katsottaessa.
     
    Viimeksi muokattu: 08.12.2008
  15. angelmoon

    angelmoon Regular member

    Liittynyt:
    16.09.2003
    Viestejä:
    207
    Kiitokset:
    0
    Pisteet:
    26
    Ihtellä on about samaan kaartin kuuluva kone. Käytän CCCPeetä ja Haalia, jostain luin ohjeet miten ne piti asentaa mutta en muista mistä. Aluksi raavin päätä myös tuolla tekstitys ongelmalla että kuva ja ääni meni epäsynkkaa. Tökkivät subit olivat .sub päätteisiä. Ongelman huomattua muunsin .sub tekstit .srt teksteiks, ja .srt tekstei käyttäes ongelmia ei ole ollut. Kaipa niilla jotain eroa sit on?
     
  16. zago

    zago Member

    Liittynyt:
    03.04.2006
    Viestejä:
    97
    Kiitokset:
    0
    Pisteet:
    16
    Joo itsellä kyllä srt-tekstitkään eivät toimineet. Nyt kuitenkin homma lähti pelittämään ja toimii ihan kivasti. Asensin vain kaiken uudesti niin alkoi toimimaan. Ongelman syytä nyt ei löytynyt, mutta pääasia on että leffat pyörii.

    Kiitos todella paljon näistä avuista, mitä jaksoitte antaa!
     
  17. _Jarvis_

    _Jarvis_ Member

    Liittynyt:
    08.01.2008
    Viestejä:
    59
    Kiitokset:
    0
    Pisteet:
    16
    Sori, en ehtiny vastailla ollenkaan kysymyksiisi =D Mutta hyvä kuulla että toimii :)
     
  18. M3G47R0N

    M3G47R0N Member

    Liittynyt:
    20.11.2007
    Viestejä:
    42
    Kiitokset:
    0
    Pisteet:
    16
    Keskustelu näyttää olevan vanha, mutta itselläni samanlainen ongelma nyt. En olisi edes uskonut että teksteistä johtuu tuo "nykiminen", mutta niinpäs johtuukin. Katson siis 720p Blu-Ray rippiä (.mkv) ja kun lisään tekstit niin alkaa tosiaan nykimään. BSPlayerin renderöinti asetuksista vaihdoin "EVR:n" tilalle "Peittokuvan sekoituksen", ja nykiminen kyllä loppui mutta tekstit eivät edelleenkään synkkaa videon kanssa. Tämän jälkeen latasin 1080p tekstit ja ne sitten toimiikin, eli asia hoidettu, mutta mistä voi johtua että 1080p tekstit toimii ja 720p tekstit ei?
     
  19. angelmoon

    angelmoon Regular member

    Liittynyt:
    16.09.2003
    Viestejä:
    207
    Kiitokset:
    0
    Pisteet:
    26
    Ovatko tekstit eri vai samaa laatua? (.sub/srt)
     
  20. Toni_S

    Toni_S Member

    Liittynyt:
    05.01.2009
    Viestejä:
    22
    Kiitokset:
    0
    Pisteet:
    11
    Täällä sama ongelma tekstien kanssa x264 tiedostojen kanssa nykii. Playerinä MPC. Alkoi ihan yht´äkkiä, ennen on toiminut ja mitään muutoksia ei ole tehty. Kone: Core2 E6400 @3,1GHz, 6Gt DDR2, 8800gt.
     
  21. xbkrypt0n

    xbkrypt0n Active member

    Liittynyt:
    16.06.2010
    Viestejä:
    3,154
    Kiitokset:
    120
    Pisteet:
    73
    Poista kaikki filtterit (cccp, vobsub, jne.) ja pistä vain ne tarpeelliset.

    Media Player Classic Home Cinema
    ffdshow
    AC3filter
    myös LAV Filters voit koittaa.

    MPC-HC käyttää oletuksena sisäisiä filttereitä. Jos video tökkii niillä, mene ffdshow:n video decoder configuration, pistä x264 disablediin, mene sitten DXVA video decoder configurationiin ja pistä se purkamaan H264 ja VC1. Sitten MPC-HC:n asetuksista pois päältä H264 ja VC1 purku internal filters -kohdasta. Voit tarkistaa millä MPC-HC näyttää videota menemällä MPC-HC:ssa Play->Filters kun pistät jonkun x264-leffan pyörimään.
     

Jaa tämä sivu