1. Tämä sivusto käyttää keksejä (cookie). Jatkamalla sivuston käyttämistä hyväksyt keksien käyttämisen. Lue lisää.

Ongelma Black screen kirjautumisen yhteydessä.

Viestiketju Windows -ongelmat -osiossa. Ketjun avasi MechaniCal. 14.01.2016.

  1. MechaniCal.

    MechaniCal. Member

    Liittynyt:
    13.06.2012
    Viestejä:
    52
    Kiitokset:
    0
    Pisteet:
    16
    Sisäänkirjautuessa näyttö pimenee. Tämä tapahtuu välillä samantien kun kosken hiireen kirjautumis ruudussa tai sitten samalla sekunilla kun työpöytä tulee näkyviin. Lisäksi kirjautuessa kuvassa vilkahtaa muutamia poikkiraitoja ja muita epämääräisiä kuvoita. Kun näytön irrottaa kirjautumisen ajaksi ja kirjoittaa salasanan sokkona, ei mustaa ruutua tule kun näytön taas kytkee kiinni.

    En tiedä liittyvätkö yhteen, mutta näytön pimenemistä esiintyy myös lähes aina kun koneen herättää lepotilasta. Vehkeet on mallia R9 290x 15.12 ajurilla, prossu xeon ja windows 10 pro 64bit.
     
  2.  
  3. *Trinity*

    *Trinity* Senior member

    Liittynyt:
    15.12.2014
    Viestejä:
    2,708
    Kiitokset:
    528
    Pisteet:
    123
    Ainakin pikaisesti miettien kuulostaisi näytönohjainvialta.
    Kun pääset Windowsiin tuolla näyttlkikalla niin lataa minitoolbox.

    http://www.bleepingcomputer.com/download/minitoolbox/

    Aukaise minitoolbox ja pistä valinta ruutuihin

    List Winsock entries
    List last 10 event viewer errors
    List installed programs
    List Devices - only problems
    List users partitions and memory size
    List minidump files

    Klikkaa Go
    Kun tarkistus on valmis niin MTB niminen tekstitiedosto aukeaa, liitä se tänne.
     
  4. MechaniCal.

    MechaniCal. Member

    Liittynyt:
    13.06.2012
    Viestejä:
    52
    Kiitokset:
    0
    Pisteet:
    16
    Tässä olisi. Ja tosiaan tuo windows päivitys ei onnistu, koska itse päivitys on virheellinen. On siis yleinen ongelma, ei omasta laitteesta johtuva.
     

    Liitetyt tiedostot:

    Viimeksi muokattu: 14.01.2016
  5. *Trinity*

    *Trinity* Senior member

    Liittynyt:
    15.12.2014
    Viestejä:
    2,708
    Kiitokset:
    528
    Pisteet:
    123
    Onko järjestelmälevy SSD?
    Siellähän oli parikin päivitystä jotka oli epäonnistunut ja toinen kahteen kertaan antaen eri virhekoodin.

    Mitään ihmeellisempää liittyen tuohon alkuperäiseen ongelmaan ei kyllä näkynyt.

    Klikkaa hiiren oikealla Windows kuvaketta ja valitse Komentokehote (järjestelmänvalvoja)
    Koipoi kometokehotteeseen seuraavat komennot.

    cd c:\
    dir *.dmp /p /s >> c:\crashfiles.txt
    Paina Enter
    Tarkistus on valmis kun komentokehotteeseen tule näkyviin c:\>
    Löydät tarkistuksen lokin
    C:\crashfiles
    Liitä se tänne.
     
  6. MechaniCal.

    MechaniCal. Member

    Liittynyt:
    13.06.2012
    Viestejä:
    52
    Kiitokset:
    0
    Pisteet:
    16
    Kyllä, Windows on SSD:llä.

     
  7. *Trinity*

    *Trinity* Senior member

    Liittynyt:
    15.12.2014
    Viestejä:
    2,708
    Kiitokset:
    528
    Pisteet:
    123
    Todennäköisesti noi on kaikki näytönohjaimesta johtuvia.

    Menetkö tuonne c:\Windows\LiveKernelReports\WATCHDOG
    Ja pistät sieltä uusimman ja vaikka vanhimman dmp. tiedoston joko pakattuna tiedostona suoraan tänne tai sitten jollekin tiedostojenjako palvelimelle ja latauslinkin tänne.
     
  8. MechaniCal.

    MechaniCal. Member

    Liittynyt:
    13.06.2012
    Viestejä:
    52
    Kiitokset:
    0
    Pisteet:
    16
    Uusin eiliseltä ja vanhin heinäkuulta, jolloin koneen kasasin.
     

    Liitetyt tiedostot:

  9. MechaniCal.

    MechaniCal. Member

    Liittynyt:
    13.06.2012
    Viestejä:
    52
    Kiitokset:
    0
    Pisteet:
    16
    Vaikuttaa tosiaan näytönohjainvialta, mutta kun tuo näytön pimeneminen käynnistyksessä tapahtuu ja painaa napista uudelleenkäynnistyksen niin tulee ilmoitus "Windows ei latautunut oikein" ja vaihtoehtoja mitä tehdä (kuvassa). Kyseessä ei kuitenkaan ole sama vika, josta moni on netissä valittanut jossa kuva on noin minuutin pimeänä ennen sisäänkirjautumista, mutta kursori jää näkyviin ja liikkuu. Minulla nuolta ei näy ja ruutu pysyy mustana, vaikka odottaa kuinka kauan.
    [​IMG]
     
  10. *Trinity*

    *Trinity* Senior member

    Liittynyt:
    15.12.2014
    Viestejä:
    2,708
    Kiitokset:
    528
    Pisteet:
    123
    Jpes kumpikin oli näytönohjaimesta.
    Eli kyseessä on ainakin näiden kohdalla Näytönohjain lakkasi vastaamasta ja palutui ongelmasta, voit lukea siitä tuosta linkistä älä kuitenkaan koita sitä korjausta koska se on Vistalle/Seiskalle, lähinä tiedoksi vain mistä on kyse.

    Voisit poistaa näytönhjainajurit käyttäen Display driver uninstalleria (DDU)
    Aukaise DDU ja seuraa ohjelman opastusta.

    Ja uudet ajurit.
    http://support.amd.com/en-us/download/auto-detect-tool
    Tai jos haluat ladata itse.
    http://support.amd.com/en-us/download/desktop?os=Windows+10+-+64

    Tuossa kun on tuo pistämäsi kuvan mukainen tilanne niin kokeile tuota Käynnistyksen korjausta.

    Toinen asia minkä voit tehdä kun olet normaalisti työpöydällä.
    Koioi komentokehotteeseen seuraava komento.
    chkdsk C: /F
    Paina Enter
    Ajoita seuraavan käynnistyksen yhteyteen valitsemalla K tai Y
    Käynnistä kone uudelleen.

    Kun olet tarkistuksen jälkeen työpöydällä.
    Ota loki seuraavasti
    Klikkaa Windows kuvaketta hiiren oikealla ja valitse Tapahtumienvalvonta - Windows lokit - Application ja etsi listasta tapahtuma nimeltä Wininit

    [​IMG]

    Ja tässä vielä tuon dmp. tiedoston tiedot.

    Koodi:
    ************* Symbol Path validation summary **************
    Response                         Time (ms)     Location
    Deferred                                       SRV*C:\Windows\symbol_cache*http://msdl.microsoft.com/download/symbols
    Symbol search path is: SRV*C:\Windows\symbol_cache*http://msdl.microsoft.com/download/symbols
    Executable search path is:
    No .natvis files found at C:\Program Files (x86)\Windows Kits\10\Debuggers\x64\Visualizers.
    Windows 10 Kernel Version 10586 MP (8 procs) Free x64
    Product: WinNt, suite: TerminalServer SingleUserTS
    Built by: 10586.17.amd64fre.th2_release.151121-2308
    Machine Name:
    Kernel base = 0xfffff803`f2c1e000 PsLoadedModuleList = 0xfffff803`f2efcc70
    Debug session time: Thu Jan 14 13:00:24.583 2016 (UTC + 2:00)
    System Uptime: 0 days 0:00:17.216
    Loading Kernel Symbols
    .
    
    Press ctrl-c (cdb, kd, ntsd) or ctrl-break (windbg) to abort symbol loads that take too long.
    Run !sym noisy before .reload to track down problems loading symbols.
    
    ..............................................................
    ................................................................
    .................................
    Loading User Symbols
    Mini Kernel Dump does not contain unloaded driver list
    *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************
    
    Use !analyze -v to get detailed debugging information.
    
    BugCheck 141, {ffffe0011c030010, fffff8014a06ce98, 0, 0}
    
    Unable to load image atikmpag.sys, Win32 error 0n2
    *** WARNING: Unable to verify timestamp for atikmpag.sys
    *** ERROR: Module load completed but symbols could not be loaded for atikmpag.sys
    Probably caused by : atikmpag.sys ( atikmpag+ce98 )
    
    Followup:     MachineOwner
    ---------
    
    6: kd> !analyze -v
    *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************
    
    VIDEO_ENGINE_TIMEOUT_DETECTED (141)
    One of the the display engines failed to respond in timely fashion.
    (This code can never be used for a real bugcheck.)
    Arguments:
    Arg1: ffffe0011c030010, Optional pointer to internal TDR recovery context (TDR_RECOVERY_CONTEXT).
    Arg2: fffff8014a06ce98, The pointer into responsible device driver module (e.g owner tag).
    Arg3: 0000000000000000, The secondary driver specific bucketing key.
    Arg4: 0000000000000000, Optional internal context dependent data.
    
    Debugging Details:
    ------------------
    
    
    BUGCHECK_P1: ffffe0011c030010
    
    BUGCHECK_P2: fffff8014a06ce98
    
    BUGCHECK_P3: 0
    
    BUGCHECK_P4: 0
    
    FAULTING_IP:
    atikmpag+ce98
    fffff801`4a06ce98 ??              ???
    
    DEFAULT_BUCKET_ID:  GRAPHICS_DRIVER_ENGINE_TIMEOUT
    
    TAG_NOT_DEFINED_202b:  *** Unknown TAG in analysis list 202b
    
    
    CPU_COUNT: 8
    
    CPU_MHZ: d46
    
    CPU_VENDOR:  GenuineIntel
    
    CPU_FAMILY: 6
    
    CPU_MODEL: 3c
    
    CPU_STEPPING: 3
    
    BUGCHECK_STR:  0x141
    
    PROCESS_NAME:  System
    
    CURRENT_IRQL:  0
    
    ANALYSIS_VERSION: 10.0.10240.9 amd64fre
    
    STACK_TEXT:
    ffffd000`ab162470 fffff801`49b672ec : ffffe001`1c030010 ffffd000`ab1625d9 00000000`000043c0 ffffe001`1c801010 : watchdog!WdDbgReportRecreate+0x104
    ffffd000`ab1624c0 fffff801`49b65e88 : ffffc000`00000000 ffffc000`9f8fa8c0 00000000`000043c0 ffffe001`1c030010 : dxgkrnl!TdrUpdateDbgReport+0xec
    ffffd000`ab162510 fffff801`4c55108d : ffffe001`1aa2d058 ffffe001`1aa2d058 ffffe001`1c030010 ffffe001`1aa2d000 : dxgkrnl!TdrCollectDbgInfoStage1+0x358
    ffffd000`ab162640 fffff801`4c5ba988 : ffffe001`1aa2d000 00000000`00000000 00000000`00000001 ffffe001`1aa2f001 : dxgmms2!VidSchiResetEngine+0x265
    ffffd000`ab162920 fffff801`4c5a7751 : ffffe001`1aa2d000 ffffe001`1aa2f000 00000000`00000000 ffffe001`1aa2f000 : dxgmms2!VidSchiResetEngines+0x84
    ffffd000`ab162960 fffff801`4c58de6d : 00000000`00000002 00000000`000003c4 00000000`0032a277 00000000`00000001 : dxgmms2! ?? ::NNGAKEGL::`string'+0x7021
    ffffd000`ab1629c0 fffff801`4c53b8b7 : 00000000`00000000 ffffe001`1aa2f000 ffffe001`1aa2f000 00000000`00000000 : dxgmms2!VidSchiWaitForSchedulerEvents+0x31d
    ffffd000`ab162a80 fffff801`4c59a5fd : ffffe001`1b3c0c40 ffffd000`ab162bd0 ffffe001`1b3c0c00 ffffe001`1aa2f000 : dxgmms2!VidSchiScheduleCommandToRun+0x3a7
    ffffd000`ab162b80 fffff801`4c59a5c0 : ffffe001`1aa2f500 ffffe001`1aa2f000 00000000`00000080 ffffe001`18694700 : dxgmms2!VidSchiRun_PriorityTable+0x2d
    ffffd000`ab162bd0 fffff803`f2c27125 : 00000005`b59bbfff fffff803`f2d657cf fffff801`00010023 00000000`00cc2627 : dxgmms2!VidSchiWorkerThread+0x80
    ffffd000`ab162c10 fffff803`f2d65906 : ffffd000`a9c80180 ffffe001`1aa30840 fffff803`f2c270e4 00000000`00000000 : nt!PspSystemThreadStartup+0x41
    ffffd000`ab162c60 00000000`00000000 : ffffd000`ab163000 ffffd000`ab15d000 00000000`00000000 00000000`00000000 : nt!KiStartSystemThread+0x16
    
    
    STACK_COMMAND:  kb
    
    FOLLOWUP_IP:
    atikmpag+ce98
    fffff801`4a06ce98 ??              ???
    
    SYMBOL_NAME:  atikmpag+ce98
    
    FOLLOWUP_NAME:  MachineOwner
    
    MODULE_NAME: atikmpag
    
    IMAGE_NAME:  atikmpag.sys
    
    DEBUG_FLR_IMAGE_TIMESTAMP:  5661c291
    
    FAILURE_BUCKET_ID:  LKD_0x141_IMAGE_atikmpag.sys
    
    BUCKET_ID:  LKD_0x141_IMAGE_atikmpag.sys
    
    PRIMARY_PROBLEM_CLASS:  LKD_0x141_IMAGE_atikmpag.sys
    
    ANALYSIS_SOURCE:  KM
    
    FAILURE_ID_HASH_STRING:  km:lkd_0x141_image_atikmpag.sys
    
    FAILURE_ID_HASH:  {c4561d61-ffbc-583d-5e1a-6fd6e42466ee}
    
    Followup:     MachineOwner
    ---------
    
    6: kd> lmvm atikmpag
    Browse full module list
    start             end                 module name
    fffff801`4a060000 fffff801`4a10a000   atikmpag T (no symbols)      
        Loaded symbol image file: atikmpag.sys
        Image path: atikmpag.sys
        Image name: atikmpag.sys
        Browse all global symbols  functions  data
        Timestamp:        Fri Dec 04 18:42:57 2015 (5661C291)
        CheckSum:         000B4981
        ImageSize:        000AA000
        Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
    Mini Kernel Dump does not contain unloaded driver list
    
     
  11. MechaniCal.

    MechaniCal. Member

    Liittynyt:
    13.06.2012
    Viestejä:
    52
    Kiitokset:
    0
    Pisteet:
    16
    Kiitoksia. DDU ja AMD-ohjelmiston uudelleenasennus poisti tuon käynnistyksen yhteydessä tapahtuvan black screenin, mutta lepotilasta herätettäessä kuva sammuu edelleen. Tein myös tuon toisen kikan. Tässä vielä teksti tuosta "Yleiset" kohdasta, josa siitä on mitään hyötyä:
    Ja "Tiedot":
     
  12. *Trinity*

    *Trinity* Senior member

    Liittynyt:
    15.12.2014
    Viestejä:
    2,708
    Kiitokset:
    528
    Pisteet:
    123
    Hyvä hyvä.
    Tuossa chkdsk lokissa ei ole ihmeempää siinä on kaikki ok.

    Tuohon lepotilasta heräämiseen en osaa oikein sanoa mitään, sen voi aaiheuttaa niin moni eri asia.
    Lähinnä tulee mieleen virranhallinta-asetusten muuttaminen mutta sen tarkemmin en osaa sanoa.
    Ehkä kannattaa ottaa leptilaan meneminen ainakin hetkeksi pois käytöstä.
    Tuolta on joku löytänyt avun.
    http://www.tenforums.com/general-discussion/5265-turn-off-wake-up-problems.html

    Tarkistetaan vielä varmuuden vuoksi järjestelmätiedostoja.
    Komentokehotteeseen seurava komento.
    sfc /scannow
    Paina Enter kerro löytyikö eheysristiriitoja.
     
  13. MechaniCal.

    MechaniCal. Member

    Liittynyt:
    13.06.2012
    Viestejä:
    52
    Kiitokset:
    0
    Pisteet:
    16
    Tuollaista kertoo
     
  14. *Trinity*

    *Trinity* Senior member

    Liittynyt:
    15.12.2014
    Viestejä:
    2,708
    Kiitokset:
    528
    Pisteet:
    123
    Ok näyttää hyvältä tuonkin suhteen.
    Seuraavalla komennolla saisi tuon tarkistuksen lokin.

    findstr /c:"[SR]" %windir%\Logs\CBS\CBS.log >"%userprofile%\Desktop\sfcdetails.txt"
    Enter ja työpöydälle ilmestyy sfcdetails niminen tekstitiedosto.

    Mutta sitä ei nyt tarvitse koska korruptoituneet tiedostot korjattiin.
    Lähinnä jos haluat itse katsoa mitä sieltä korjattiin.

    Enempää ei liene tarvitse käydä, tuohon lepotilasta palaamiseen en valitettavasti osaa sanoa mitään, mutta kannattaa selailla eri sivuja ja katsoa mikä muilla on auttanut.
     
  15. MechaniCal.

    MechaniCal. Member

    Liittynyt:
    13.06.2012
    Viestejä:
    52
    Kiitokset:
    0
    Pisteet:
    16
    Kiitos avusta. Harmi kyllä tuo käynnistysvika ilmaantui uudestaan, vaikka se jo jonkin aikaa toimikin. Voisi kokeilla vaikuttaako, jos vaihtaa näytönohjaimen BIOSin. Ohjain kuitenkin toimii hyvin ja vakaasti kellotettuna kovassakin rasituksessa, joten ei luulisi mikään vakava vika olevan. Ainakin tuli tuo käyttöjärjestelmä suljettua pois syistä.
     
    Viimeksi muokattu: 16.01.2016
  16. MechaniCal.

    MechaniCal. Member

    Liittynyt:
    13.06.2012
    Viestejä:
    52
    Kiitokset:
    0
    Pisteet:
    16
    Ei kuulu enää Windows-osioon, mutta ongelma taitaa olla nyt juurikin näytönohjaimen bios. Käytössä on siis saman kortin tehdasylikellotetun mallin bios. Kun poistin msi afterburnerin ja kellotukset käytöstä, lakkasi kortti toimimasta ollenkaan. Vikasietotilassa sain poistettua myös ajurit ja nyt pystyn sentään käyttämään konetta normaalitilassa. Nyt vain pitäisi löytää toimiva bios-versio, mielellään alkuperäinen jonka flashata.

    E: Ja loppujen lopuksi tuo käynnistysongelma näyttää johtuvan yksinkertaisesti amd:n uusista ajureista. Monella sama ongelma, eikä ole vielä ratkaisua löytynyt.
     
    Viimeksi muokattu: 16.01.2016
  17. *Trinity*

    *Trinity* Senior member

    Liittynyt:
    15.12.2014
    Viestejä:
    2,708
    Kiitokset:
    528
    Pisteet:
    123
    Jos vain valmistajalta on uudempaa biosia niin kannattaa kokeilla.
    Täältä löytyy vanhempia AMD ajureita http://support.amd.com/en-us/download/desktop/previous?os=Windows 7 - 64
    Pikaisesti kun katsoin niin näytti ainakin osa olevan Win7:le mutta eipä sinä menetä kuin aikaa jos niitä kokeilee.
    Ja tietysti valmistajan sivulta löytynee yleensä pari vanhempaa ajuria.
     
  18. MechaniCal.

    MechaniCal. Member

    Liittynyt:
    13.06.2012
    Viestejä:
    52
    Kiitokset:
    0
    Pisteet:
    16
    Nyt ainakin toistaiseksi toimii uusimmilla ajureilla. Asensin siis pelkän ajurin, en mitään muuta mukana tulevaa. Vian aiheuttaja siis saattaa olla tuo amd:n oma overdrive-kellotus, joka on ennenkin todettu epävakaaksi. Lisäksi päivittelin emon biosin. Samalla näyttäisi tuo lepotilasta herätyskin korjaantuneen. Toivottavasti toimii vielä huomennakin..
     

Jaa tämä sivu