1. Tämä sivusto käyttää keksejä (cookie). Jatkamalla sivuston käyttämistä hyväksyt keksien käyttämisen. Lue lisää.

Kysymys Office365, Excel ja JOS-funktio

Viestiketju Ajuri- ja softaongelmat -osiossa. Ketjun avasi Abexi 20.11.2015.

  1. Abexi

    Abexi Member

    Liittynyt:
    08.04.2005
    Viestejä:
    72
    Kiitokset:
    0
    Pisteet:
    16
    Morjesta pöytään,

    Ongelmana on luoda oikea funktio.

    Tarvitsisi saada excel käyttämään oikeaa kaavaa solussa olevan TEKSTIN mukaan.

    Eli jos tietyssä solussa D2 on teksti "ESIMERKKI", niin excel luo soluun D3 laskutoimituksen A1+A2, mutta JOS taas solussa D2 on teksti "MALLI", niin excel luo samaiseen D3-soluun laskutoimituksen B1+B2.

    Eli mitä funktioita pitää käyttää, mieluiten suomenkielellä, Office 365 excelissä (ver. 2015?).

    Googlaamalla en osannut vastausta löytää juuri tällaiselle esimerkille.

    Kiitos.
     
  2.  
  3. Abexi

    Abexi Member

    Liittynyt:
    08.04.2005
    Viestejä:
    72
    Kiitokset:
    0
    Pisteet:
    16
    Vastaus löytyi jo omatoimisella testauksella.
    =JOS(D3="ESIMERKKI";(B3*C3*E3/12);JOS(D3="MALLI";(B3*C3*E3);JOS(D3="TESTI";(B3*C3*E3*52/12);0)))
     

Jaa tämä sivu