1. Tämä sivusto käyttää keksejä (cookie). Jatkamalla sivuston käyttämistä hyväksyt keksien käyttämisen. Lue lisää.

Merkillisiä nopeuseroja

Viestiketju WLAN ja lähiverkot -osiossa. Ketjun avasi 1pertti 06.11.2014.

  1. 1pertti

    1pertti Senior member

    Liittynyt:
    10.09.2008
    Viestejä:
    6,262
    Kiitokset:
    592
    Pisteet:
    173
    Olen usein huomannut, että nopeusmittauksen tulos vaihtelee selaimen mukaan, ja nyt selvittelin asiaa systemaattisesti. Käytössä on 100/10 Mb/s kaapelinetti ja Cisco EPC 3825 WLAN-modeemi. Tein kummallakin selaimella 10 mittausta sekä langallisella että langattomalla yhteydellä.

    IE11 LAN-tulokset olivat varsin tasaisia: latenssi 9 ms, latausnopeus keskiarvo 94,07 Mb/s ja lähetysnopeus ka. 9,78 Mb/s
    Firefoxin LAN-tuloksissa oli suurempi vaihtelu, latenssi ka. 43, latausnopeus ka. 66,23 Mb/s ja lähetysnopeus ka. 9,76 Mb/s

    Firefoxin mittaustuloksissa huomiota kiinnitti myös suuri hajonta: lantessi vaihteli kymmeniä millisekunteja mittauskertojen välillä, yksittäinen pienin latausnopeus oli 42,19 Mb/s ja suurin 83,78 Mb/s. IE:llä mittaustulokset vaihtelivat vain + 1 Mb/s

    WLAN-yhteydellä IE-tulokset pysyivät tasaisina, mutta latausnopeus putosi 51,42 Megabittiin. Firefoxilla vaihtelut olivat edelleen suuria, mutta keskiarvo 67,14 Mb/s on parempi kuin IE:llä ja jopa parempi kuin Firefoxin langallisella yhteydellä. Jälkimmäinen ero on tosin sen verran pieni, että se todennäköisesti johtuu satunnaisista vaihteluista eri mittauskerroilla.

    Mikä voisi selittää noin suuret erot latausnopeudessa ja latenssissa IE:n ja Firefoxin välillä LAN-yhteydellä? Entä mikä pudottaa IE:n nopeuden selvästi Firefoxin alapuolelle WLAN-yhteydellä? Niin tietoja kuin valistuneita arvauksiakin otetaan vastaan.
     
  2.  
  3. IlmoPJ

    IlmoPJ Moderator Ylläpitäjä

    Liittynyt:
    17.03.2006
    Viestejä:
    6,393
    Kiitokset:
    672
    Pisteet:
    193
    Tein ihan mielenkiinnosta saman testin.
    Käytössä on Welhon 100/10 Mb/s kaapeli ja Cisco EPC 3825 WLAN-modeemi, eli ilmeisesti sama kuin sinulla.
    Langatonta yhteyttä en kokeillut.
    Koodi:
    Explorer11 PING 9ms, 98,34/9,95Mbps
    Firefox    PING 9ms, 98,34/9,99Mbps
    Chrome     PING 9ms, 98,35/9,94Mbps
    Toistuvilla mittauskerroilla hajonta ei ollut suurempi, mitä noissa luvuissa näkyy.
     
    1pertti kiitti tästä.
  4. 1pertti

    1pertti Senior member

    Liittynyt:
    10.09.2008
    Viestejä:
    6,262
    Kiitokset:
    592
    Pisteet:
    173
    Kiitos. Noinhan sen pitäisi ollakin eli minulla on jotakin häikkää Firefoxissa tai sitten joku sen liitännäinen sotkee liikennettä.

    Edit. Kokeilin käynnistää Firefoxin ilman lisäosia ja sama tahmeus jatkui.
    Edit2. Ajelin nopeustestejä Windowsin vikasietotilassa. Firefoxin tulokset olivat tasaisempia, mutta silti selvästi IE:tä hitaampia. IE:llä puolestaan latenssi oli suurempi.

    Jotakin mystistä tässä on. Firefoxin verkkoasetuksistakaan en löytänyt mitään epäilyttävää, esim. proxy-asetusta tms.
     
    Viimeksi muokattu: 07.11.2014
  5. xbkrypt0n

    xbkrypt0n Active member

    Liittynyt:
    16.06.2010
    Viestejä:
    3,154
    Kiitokset:
    120
    Pisteet:
    73
  6. 1pertti

    1pertti Senior member

    Liittynyt:
    10.09.2008
    Viestejä:
    6,262
    Kiitokset:
    592
    Pisteet:
    173
    Kiitos ehdotuksesta, jota kokeilin. Loin uuden profiilin pelkästään tätä kokeilua varten, mutta myös tällä neitseellisellä profiililla nopeustulokset olivat samoja. Sama ongelma on myös vanhemmissa XP-koneissa. Mainittakoon, että kaikissa on Firefoxin viimeisin ESR-versio 31.2.o, mutta ei ESR-versiosta pitäisi seurata tällaisia ongelmia.

    Sellainen asia on selvinnyt tässä illan mittaan, että kun Firefoxissa avaa jonkun nopeustestisivun, käynnistyy samalla plugin-container.exe-prosessi ja Win 7 -koneessa lisäksi FlashPlayerPlugin, ja nämä vievät merkittävästi prosessorin kapasiteettia. IE ei tuollaisia lisäprosesseja käynnistä.
     

Jaa tämä sivu