1. Tämä sivusto käyttää keksejä (cookie). Jatkamalla sivuston käyttämistä hyväksyt keksien käyttämisen. Lue lisää.

Blender Suse 9.3

Viestiketju Linux -keskustelu -osiossa. Ketjun avasi eftu 18.07.2005.

  1. eftu

    eftu Regular member

    Liittynyt:
    29.03.2005
    Viestejä:
    165
    Kiitokset:
    0
    Pisteet:
    26
    Eli miten minä saan Blenderin Suse 9.3een. Tuolta voi ladata lähdekoodina koko paketin http://www.blender3d.com/cms/Blender.31.0.html ,mutten osaa kääntää koodia Suselle luettavaan muotoon, enkä edes tiedä mikä tiedosto noista on oikea. Tähän mennessä olen avannut vain noita helppoja .rpm paketteja, ja kun olen koittanut asentaa jotain .tar.bz-tyyppistä niin en ole koskaan onnistunut.
    Joten voisiko joku guru antaa minulle mahdollisimman selkeät ja mieluiten yksinkertaiset ohjeet, miten se paketti käännetään sitten. Kiiiitos paljon etukäteen.
     
  2.  
  3. Jannejt

    Jannejt Moderator Ylläpitäjä

    Liittynyt:
    10.02.2005
    Viestejä:
    5,046
    Kiitokset:
    5
    Pisteet:
    118
    eli pura eka:
    [bold]tar xvjf paketti.tar.bz2[/bold]
    mene hakemistoon minkä se luultavasti purki
    [bold]cd /hakemisto/minka/ehka/purki[/bold]
    sitten tarkasta onko kaikki tarvittavat kääntäjät jne. asennettu
    [bold]./configure[/bold]
    sitten jos se menee läpi:
    [bold]make[/bold]
    sitten viimesenä asennetaan roottina paketti:
    [bold]su[/bold]
    *salasana*
    [bold]make install[/bold]
     
  4. lunix

    lunix Regular member

    Liittynyt:
    01.07.2004
    Viestejä:
    773
    Kiitokset:
    0
    Pisteet:
    26
  5. eftu

    eftu Regular member

    Liittynyt:
    29.03.2005
    Viestejä:
    165
    Kiitokset:
    0
    Pisteet:
    26
    No katos. Tuolta jakelustahan se löytyikin en tajunnut ensin vain katsoa tarpeeksi tarkkaan. Kiitos mahdottomasti. Asennetaanko nuo muutkin .tar.bz(ja tuon tapaiset) samalla tavalla. Tuo ei todellakaan näyttänyt vaikealta :D
     
  6. kuassa

    kuassa Guest

    Kyllä, tuo on se perustapa kääntää paketteja. Ei todellakaan vaikea. Suurimman osan paketeista pitäisi mennä suoraan tuolla mainitulla tavalla.

    Ainoaksi ongelmaksi voi tulla joittenkin kirjastojen riippuvuudet tai joittenkin puuttuminen mitä nuo ohjelmat tarvitsevat.

    Jotkut ohjelmat tarvitsevat kehitys version(dev) noista kirjastoista että ne voidaan kääntää ja niitä ei yleensä ole asennettu valmiiksi jos niitä ei erikseen hae.

    Mutta riippuuvuudet onkin se todellinen ongelma johon joissain tapauksissa voi törmätä. Kun jokin ohjelma tarvitsee tietyn kirjaston version, toinen ohjelma voikin vaatia toimiakseen itsestään uudemman version ja muita uusia kirjastoja jotta on yhteensopiva tuon tietyn kirjaston kanssa. Tuosta voi tulla kierre. Siksi useimmissa linux jakeluissa onkin pakettien hallinta, jotta ei tulisi joka toinen paketti sellaisia ristiriitoja. Olen kumminkin itse aika harvoin törmännyt kyseiseen ongelmaan.
     
  7. eftu

    eftu Regular member

    Liittynyt:
    29.03.2005
    Viestejä:
    165
    Kiitokset:
    0
    Pisteet:
    26
    Joo kiitos kovasti, luulin ennen että tuo kääntäminen on aivan mahdotonta puuhaa mutta kyllähän tuo onnistui :p
     

Jaa tämä sivu