1. Tämä sivusto käyttää keksejä (cookie). Jatkamalla sivuston käyttämistä hyväksyt keksien käyttämisen. Lue lisää.

Äänilaitteen/ajurien resetointi

Viestiketju Ajuri- ja softaongelmat -osiossa. Ketjun avasi Tonttuman 28.01.2015.

  1. Tonttuman

    Tonttuman Regular member

    Liittynyt:
    11.01.2007
    Viestejä:
    181
    Kiitokset:
    18
    Pisteet:
    28
    Elikkäs koneessa on ESI Juli@ -äänikortti.
    Kortin kanssa on kohtuu yleinen ongelma (eli muillakin) että koneen lepotilasta palatessa äänilaite tai sen ajurit jäävät jumiin, jonka seurauksena mitään ääntä ei laitteesta saa ulos. Itse asiassa mikään soitin ei edes pyöritä ääntä. Tämän korjaa koneen uudelleenkäynnistys.

    Välttääkseni uudelleenkäynnistykset, kokeilin seuraavaa kikkaa .bat tiedostosta suoritettuna, tuloksetta:
    net stop audiosrv
    net stop AudioEndpointBuilder
    net start AudioEndpointBuilder
    net start audiosrv

    Olisiko siis olemassa jotain komentoa jolla saisi ladattua ainoastaan nuo äänikortin ajuritiedostot uudelleen uudelleenkäynnistämättä konetta? Tuo yllämainittu kun taitaa vain resetoida tuon äänipalvelun. Ja kyllä, olen jo kertaalleen asentanut kortin ajurit uudelleen. Tämä näyttää tiedossa olevalta ongelmalta jonka valmistaja on haluton korjaamaan. Olen myös laitehallinnassa kokeillut ottaa laitteen pois käytöstä ja uudelleen käyttöön, mutta tämä ei myöskään korjaa ongelmaa.
     
  2.  
  3. Tonttuman

    Tonttuman Regular member

    Liittynyt:
    11.01.2007
    Viestejä:
    181
    Kiitokset:
    18
    Pisteet:
    28
    Vastaan nyt omaan vanhaan ketjuuni, jos nyt joku on törmännyt tähän etsiessään ongelmaan ratkaisua. Ongelmaksi paljastui ilmeisesti Windowsin "nopea käynnistys" -valinta joka näköjään jätti lataamatta tai latasi väärin äänikortin ajureita. Uudelleenkäynnistys ei ole "nopea käynnistys" joten tämän jälkeen homma toimii normaalisti. "Nopean käynnistyksen" valinnan saa poistettua ohjauspaneelista virranhallinta-asetusten alta, painikkeiden määrittelystä. Tämä näyttäisi ratkaisseen ongelmani, vaikka ilmeisesti loppujen lopuksi taitaa olla kyse huonosti tehdyistä ajureista.
     

Jaa tämä sivu